Skip to main content
VulnerabilityPublished

CVE-2026-52817: Linuxfabrik Monitoring Plugins · Sudoers may be able to obtain privilege escalation via /usr/bin/apt-get arguments

Affects linuxfabrik-libSource GCVE Database

0
Authoritative record:CVE-2026-52817· High 7.0

Public exploit available · CVSS 7.0 High : upgrade to 5.1.0 as a priority.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 18 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitHub, Inc.

    , 71 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 22 hours after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade linuxfabrik-lib to 5.1.0.

Affected software

ProductAffectedFixed in
PyPIlinuxfabrik-libAffected
  • <5.1.0
Fixed in
  • 5.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available that restricts the allowed apt-get commands and arguments in the sudoers file to only those specifically needed by the monitoring plugins. Users should update to linuxfabrik-lib version 5.1.0 or later. Until patched, manually restrict the sudoers entry for apt-get to only allow specific arguments, such as 'apt-get update --quiet 2', to prevent arbitrary command execution. No other mitigation is indicated by the vendor advisory.

Description

Linuxfabrik Monitoring Plugins provides monitoring plugins for Icinga, Nagios, and related systems. Prior to version 5.1.0, the shipped assets/sudoers/Debian.sudoers policy allowed the nagios or icinga account to execute /usr/bin/apt-get as root without restricting its arguments. An attacker who already controls that monitoring account can supply the APT::Update::Pre-Invoke option to execute an arbitrary command while apt-get runs with root privileges, resulting in a root shell and complete compromise of the host. The vulnerable rule supports the check-plugins/deb-updates/deb-updates plugin, but it authorized arbitrary apt-get argument sequences rather than only the required apt-get update --quiet 2 command. This issue is fixed in version 5.1.0.

References

Community reviews

Loading reviews…