Skip to main content
VulnerabilityPublished

CVE-2026-42798: Little CMS (lcms2) 2.16 through 2.18 before 2.19 has an integer overflow in ParseCube in cmscgats.c

Source GCVE Database

0
Authoritative record:CVE-2026-42798· Medium 4.0

Not known to be exploited · CVSS 4.0 Medium : upgrade to 2.19 when convenient.

Data as of 27 Oct 2026, 00:18 UTC

CVSS 3.1 base score
4.0Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.19
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade little cms color engine and mm2/Little-CMS to 2.19.

Affected software

ProductAffectedFixed in
littlecmslittle cms color engineAffected
  • >=2.16 <2.19
Fixed in
  • 2.19
GitHubmm2/Little-CMSpkg:github/mm2/Little-CMSOther threatsAffected
  • =2.16
  • >=2.17 <2.19
Fixed in
  • 2.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Little CMS version 2.19 or later, where this integer overflow vulnerability in ParseCube is fixed. No other mitigation or temporary workaround is indicated.

Description

Little CMS (lcms2) versions 2.16 through 2.18 have an integer overflow vulnerability in the ParseCube function within the cmscgats.c file. This flaw is addressed in version 2.19.

References

Community reviews

Loading reviews…