Skip to main content
CVE-2026-120315VulnerabilityPublished

LobeHub Chat from 1.84.26 before 2.1.49 contains a path traversal vulnerability that allows authenticated users to

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-120315· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 2.1.49 soon.

Data as of 2 Nov 2026, 04:43 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 2.1.49
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade chat to 2.1.49.

Affected software

ProductAffectedFixed in
lobehubchatAffected
  • >=1.84.26 <2.1.49
Fixed in
  • 2.1.49
npmchatpkg:npm/chatOther threatsAffected
  • >=1.84.26 <2.1.49
Fixed in
  • 2.1.49

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version is available starting from 2.1.49. Users should upgrade to version 2.1.49 or later to remediate this vulnerability. No other mitigation or temporary workaround is specified.

Description

LobeHub Chat versions from 1.84.26 up to but not including 2.1.49 contain a path traversal vulnerability. Authenticated users can exploit this flaw by supplying unsanitized file names to the writeTempFile() function, enabling arbitrary file writes. This can lead to overwriting critical application files such as startServer.js, potentially resulting in remote code execution or denial of service.

References

Community reviews

Loading reviews…