Mariadb 10.3: From versions 10.6.1 to before 10.6.27, 10.11.1 to before 10.11.18, 11.4.1 to before 11.4.12, 11.8.1 to
Affects mariadb-10.3Source GCVE Database
Not known to be exploited · CVSS 8.0 High : upgrade to 1:11.8.6-5ubuntu0.1 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1:11.8.6-5ubuntu0.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade the Ubuntu mariadb package to 1:11.8.6-5ubuntu0.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSmariadbpkg:deb/ubuntu/mariadb?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10mariadbpkg:deb/ubuntu/mariadb?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSmariadbpkg:deb/ubuntu/mariadb?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSmariadb-10.6pkg:deb/ubuntu/mariadb-10.6?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSmariadb-10.3pkg:deb/ubuntu/mariadb-10.3?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches provided by MariaDB and Ubuntu by upgrading to versions 10.6.27, 10.11.18, 11.4.12, 11.8.8, or later as appropriate. For Ubuntu users, update to package version 1:11.8.6-5ubuntu0.1 or later as per Ubuntu Security Notice USN-8536-1. No additional mitigations are required once the patch is applied.
Description
MariaDB server versions 10.6.1 to before 10.6.27, 10.11.1 to before 10.11.18, 11.4.1 to before 11.4.12, 11.8.1 to before 11.8.8, and 12.3.1 contain a vulnerability in the rsync State Snapshot Transfer (SST) method. During SST, the donor node interpolates parameters sent by the joiner node into the command line without proper validation, allowing a malicious joiner to execute arbitrary shell commands on the donor. This critical vulnerability has been patched in versions 10.6.27, 10.11.18, 11.4.12, 11.8.8, and 12.3.2.