MasterStudy LMS plugin for WordPress before 3.7.50 contains a missing authorization vulnerability that allows any
Source GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.7.50 when convenient.
Data as of 29 Oct 2026, 15:55 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 4.3 |
- Patch
- Available – fixed in 3.7.50
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade MasterStudy LMS WordPress Plugin to 3.7.50.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| StylemixMasterStudy LMS WordPress Plugin | Affected
| Fixed in
|
AI-suggested
A fix is available in MasterStudy LMS plugin version 3.7.50 and later. Users should upgrade to version 3.7.50 or newer to remediate this vulnerability. Until patched, disabling PHP error display (display_errors) can prevent filesystem path disclosure. Additionally, restricting authenticated user roles or limiting access to the affected AJAX action may reduce risk.
Description
The MasterStudy LMS plugin for WordPress versions before 3.7.50 has a missing authorization vulnerability. This flaw allows any authenticated user, including those with minimal privileges such as Subscribers, to trigger the stm_lms_send_test_email_ajax AJAX action without proper capability or nonce validation. Exploitation can lead to an uncaught PHP fatal error that may disclose the absolute filesystem path of the plugin if PHP error display is enabled.
References
- nvd.nist.gov/vuln/detail/CVE-2026-80069 (opens in a new tab)
- docs.stylemixthemes.com/masterstudy-lms/changelog-free-version (opens in a new tab)
- wordpress.org/plugins/masterstudy-lms-learning-management-system (opens in a new tab)
- vulncheck.com/advisories/masterstudy-lms-wordpress-plugin-missing-authorization-via-stm-lms-send-test-email-ajax (opens in a new tab)