CVE-2026-4646: Mattermost server · Mattermost doesn't validate user-supplied input in API request handlers
Affects github.com/mattermost/mattermost-serverSource GCVE Database
Not known to be exploited · CVSS 4.3 Medium : upgrade to 11.6.1 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 11.6.1, 11.5.4, 11.4.5 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 26 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gogithub.com/mattermost/mattermost-server | Affected
| Fixed in
|
| Gogithub.com/mattermost/mattermost-server | Affected
| Fixed in
|
| Gogithub.com/mattermost/mattermost-server | Affected
| Fixed in
|
| Gogithub.com/mattermost/mattermost-server | Affected
| Fixed in
|
| Gogithub.com/mattermost/mattermost-plugin-github | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
In the meantime, restricting authenticated user access to trusted parties may reduce risk.
Description
Mattermost versions 10.11.0 through 10.11.14, 11.4.0 through 11.4.4, 11.5.0 through 11.5.3, and 11.6.0 are affected by a vulnerability where user-supplied input in API request handlers is not properly validated. This flaw allows an authenticated attacker to crash the plugin process by sending a crafted HTTP request to the pull request details endpoint. The vulnerability has been assigned CVE-2026-4646 and is categorized under CWE-1287.