Skip to main content
Report · SecurityWeekAbout CVE-2026-97229Published

Max-Severity GitLab Vulnerability Exploited Against Alpine Linux

Affects GitLab Community Edition and Enterprise EditionSource SecurityWeek

0
Compare
Authoritative record:CVE-2026-97229· Critical 10.0

Exploited in the wild · KEV due 1 Nov 2026 · 18% EPSS · fixed in 19.4.2 : patch GitLab Community Edition and Enterprise Edition now.

Data as of 30 Oct 2026, 11:45 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitLab)CVSS 3.110.0
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
EPSS
18.4% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 19.4.2, 19.3.5, 19.2.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 16 days after disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitLab Inc.

    , 19 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    exploitation active

    , 16 days after disclosure

  4. In Threat Radar

    record ingested

    , 16 days after disclosure

  5. , 16 days after disclosure

  6. KEV remediation due

    US federal deadline

    , 19 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade GitLab to 19.4.2, 19.3.5 or 19.2.8.

Affected software

ProductAffectedFixed in
GitLabGitLabAffected
  • >=19.4 <19.4.2
Fixed in
  • 19.4.2
GitLabGitLabAffected
  • >=19.3 <19.3.5
Fixed in
  • 19.3.5
GitLabGitLabAffected
  • >=19.2 <19.2.8
Fixed in
  • 19.2.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

CVE-2026-97229 is a critical code execution vulnerability in GitLab caused by insufficient validation in Ruby's Onigmo regular expression engine. It allows unauthenticated attackers to execute arbitrary code on the GitLab server via crafted CI/CD configurations. The vulnerability was exploited in an attempted attack against Alpine Linux's GitLab instance, which failed but prompted a full rebuild and password resets. The flaw is rooted in Ruby, not GitLab itself, requiring updates to Ruby versions 3.3.13, 3.4.12, 4.0.9 or later for full remediation. The US CISA has added this vulnerability to its Known Exploited Vulnerabilities catalog, urging rapid patching.

References

Community reviews

Loading reviews…