Mbed TLS before 3.6.4 has a PEM parsing one-byte heap-based buffer underflow, in mbedtls_pem_read_buffer and two
Source GCVE Database
Not known to be exploited · CVSS 4.8 Medium : upgrade to 3.6.4 when convenient.
Data as of 30 Oct 2026, 01:44 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 4.8 |
|---|
- Patch
- Available – fixed in 3.6.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 4 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mbed-tls/mbedtls to 3.6.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubmbed-tls/mbedtlspkg:github/mbed-tls/mbedtlsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in Mbed TLS version 3.6.4. Users should upgrade to version 3.6.4 or later to remediate this issue. No other mitigation or workaround information is provided.
Description
Mbed TLS versions prior to 3.6.4 contain a heap-based buffer underflow vulnerability in PEM parsing functions when processing untrusted PEM input. This flaw affects the functions mbedtls_pem_read_buffer and two mbedtls_pk_parse variants. The vulnerability can lead to a one-byte buffer underflow on the heap.