CVE-2026-24486: Mcp proxy · Python-Multipart has Arbitrary File Write via Non-Default Configuration
Affects mcp-proxySource GCVE Database
Public exploit available (Exploit-DB) · CVSS 8.6 High : upgrade to 0.11.0_1 as a priority.
Data as of 4 Nov 2026, 07:01 UTC
- Patch
- Available – fixed in 0.11.0_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:LExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 27 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by GitHub, Inc.
, 4 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 17 minutes after disclosure
First Exploit-DB entry (opens in a new tab)
Python-Multipart 0.0.22 - Path Traversal
, 93 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade mcp-proxy to 0.11.0_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-proxypkg:brew/mcp-proxyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade mcp-proxy to version 0.11.0_1 or later where the vulnerability is fixed. Alternatively, avoid using the configuration option UPLOAD_KEEP_FILENAME=True to prevent exploitation.
Description
A path traversal vulnerability in mcp-proxy's Python-Multipart library allows arbitrary file write when using non-default configuration options UPLOAD_DIR and UPLOAD_KEEP_FILENAME=True. An attacker can craft filenames starting with '/' to bypass the intended upload directory and write files to arbitrary filesystem locations. This affects versions from 0.8.2 up to but not including 0.11.0_1. The default configuration is not vulnerable. The issue is fixed in version 0.11.0_1.
References
- github.com/Kludex/python-multipart/security/advisories/GHSA-wp53-j4wj-2cfg (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-24486 (opens in a new tab)
- github.com/Kludex/python-multipart/commit/9433f4bbc9652bdde82bbe380984e32f8cfc89c4 (opens in a new tab)
- github.com/Kludex/python-multipart (opens in a new tab)
- github.com/Kludex/python-multipart/releases/tag/0.0.22 (opens in a new tab)