Skip to main content
VulnerabilityPublished Updated

CVE-2026-44681: Mcpm · Authlib OIDC Implicit/Hybrid Authorization Vulnerable to Open Redirect

Affects mcpmSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.14.0_4 when convenient.

Data as of 30 Oct 2026, 07:00 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.14.0_4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mcpm to 2.14.0_4.

Affected software

ProductAffectedFixed in
Homebrewmcpmpkg:brew/mcpmOther threatsAffected
  • >=2.1.0 <2.14.0_4
Fixed in
  • 2.14.0_4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Authlib version 2.14.0_4. Users should upgrade to this version or later to remediate the vulnerability. The patch ensures that redirect_uri is validated before any error response that issues a redirect. No additional mitigation actions are required once the update is applied.

Description

CVE-2026-44681 is an open redirect vulnerability in Authlib's OpenIDImplicitGrant and OpenIDHybridGrant authorization endpoints. An attacker can cause the authorization server to issue an HTTP 302 redirect to an arbitrary URL by submitting an authorization request that omits the required 'openid' scope. This occurs because the scope validation error redirects to an unvalidated redirect_uri supplied by the attacker. The flaw affects Authlib versions from 2.1.0 up to but not including 2.14.0_4 and is fixed in version 2.14.0_4. The vulnerability enables phishing attacks leveraging the trusted authorization server domain but does not leak tokens or codes directly.

References

Community reviews

Loading reviews…