CVE-2026-28490: Mcpm · Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle
Affects mcpmSource GCVE Database
Not known to be exploited · CVSS 8.3 High : upgrade to 2.13.0_3 soon.
Data as of 30 Oct 2026, 07:14 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.13.0_3
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcpm to 2.13.0_3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcpmpkg:brew/mcpmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Authlib version 2.13.0_3 that removes the explicit CEK length exception and restores the Bleichenbacher mitigation by relying on the cryptography library's randomized output and AES-GCM tag validation. Users should upgrade to Authlib 2.13.0_3 or later to eliminate the exception oracle. No additional configuration is required once patched. Until patched, disabling the RSA1_5 algorithm or avoiding its use may mitigate exposure.
Description
A cryptographic padding oracle vulnerability exists in the Authlib Python library's implementation of the JWE RSA1_5 key management algorithm. Authlib disables the Bleichenbacher mitigation provided by the underlying cryptography library by raising a distinct exception on invalid padding, creating a reliable exception oracle. This vulnerability is active by default in Authlib versions from 2.1.0 up to but not including 2.13.0_3. The flaw allows attackers to distinguish invalid padding from valid padding with incorrect MAC, potentially enabling cryptographic attacks. A fix is available in Authlib version 2.13.0_3.
References
- github.com/authlib/authlib/security/advisories/GHSA-7432-952r-cw78 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-28490 (opens in a new tab)
- github.com/authlib/authlib/commit/48b345f29f6c459f11c6a40162b6c0b742ef2e22 (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.6.9 (opens in a new tab)