Skip to main content
CVE-2026-89020VulnerabilityPublished Updated

MikroTik RouterOS before 7.23.4 (long-term) and 7.24.2 (stable) contains a stack-based buffer overflow vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-89020· High 8.7

Not known to be exploited · CVSS 8.7 High · fixed in 7.24.2 : patch RouterOS soon.

Data as of 6 Nov 2026, 22:48 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 7.24.2, 7.23.4, 6.49.21
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade RouterOS to 7.24.2, 7.23.4 or 6.49.21.

Affected software

ProductAffectedFixed in
MikroTikRouterOSAffected
  • >=7.24.0 <7.24.2
Fixed in
  • 7.24.2
MikroTikRouterOSAffected
  • >=7.0.0 <7.23.4
Fixed in
  • 7.23.4
MikroTikRouterOSAffected
  • >=6.0.0 <6.49.21
Fixed in
  • 6.49.21

AI-suggested

A fix is available in MikroTik RouterOS versions 7.23.4 (long-term) and 7.24.2 (stable). Users should upgrade to these or later versions to remediate the vulnerability. Until patched, restrict access to authenticated users with read-only group membership to trusted personnel only. Monitor vendor advisories for official patch releases and further guidance.

Description

MikroTik RouterOS versions before 7.23.4 (long-term) and 7.24.2 (stable) have a stack-based buffer overflow vulnerability in the mtget binary's TFTP RRQ builder function. Authenticated users with read-only group membership can crash the mtget worker process by supplying a crafted URL path of 507 bytes or more to the /tool fetch command. This overflow occurs due to an unbounded write beyond a 528-byte buffer, causing process crash without needing elevated privileges or a reachable TFTP server.

References

Community reviews

Loading reviews…