Skip to main content
VulnerabilityPublished Updated

CVE-2024-9164: GitLab · Missing Authentication

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.4.2 : patch gitlab as a priority.

Data as of 26 Oct 2026, 08:30 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.4.2, 17.3.5, 17.2.9

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.4.2, 17.3.5 or 17.2.9.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=12.5.0 <17.2.9
  • >=17.3.0 <17.3.5
  • >=17.4.0 <17.4.2
Fixed in
  • 17.2.9
  • 17.3.5
  • 17.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches provided by GitLab for the affected versions: upgrade to versions 17.2.9 or later if on the 12.5 to 17.2.9 range, 17.3.5 or later if on the 17.3 range, and 17.4.2 or later if on the 17.4 range. Since patchAvailable is true, remediation is available and should be applied promptly.

Description

A critical vulnerability (CVE-2024-9164) in GitLab Enterprise Edition allows unauthorized users to run pipelines on arbitrary branches. This affects multiple version ranges starting from 12.5 up to versions before 17.2.9, 17.3 before 17.3.5, and 17.4 before 17.4.2. The issue is due to missing authentication for a critical function. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…