Skip to main content
VulnerabilityPublished Updated

CVE-2024-5318: GitLab · Missing Authorization

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.0.1 : update gitlab when convenient.

Data as of 26 Oct 2026, 08:30 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.0.1, 16.11.3, 16.10.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.0.1, 16.11.3 or 16.10.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=11.11.0 <16.10.6
  • >=16.11.0 <16.11.3
  • >=17.0.0 <17.0.1
Fixed in
  • 16.10.6
  • 16.11.3
  • 17.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should upgrade to versions 16.10.6 or later, 16.11.3 or later, or 17.0.1 or later to remediate this vulnerability. Applying these official fixes will prevent unauthorized access by Guest users to private project dependency lists.

Description

A missing authorization vulnerability in GitLab CE/EE allows Guest users to view dependency lists of private projects via job artifacts. This affects multiple version ranges starting from 11.11 up to versions fixed in 16.10.6, 16.11.3, and 17.0.1. The issue is classified as medium severity and has an available patch.

References

Community reviews

Loading reviews…