CVE-2024-8114: GitLab · Missing Authorization
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 17.6.1 : patch gitlab soon.
Data as of 26 Oct 2026, 09:15 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.6.1, 17.5.3, 17.4.5
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.6.1, 17.5.3 or 17.4.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading GitLab to versions 17.4.5, 17.5.3, or 17.6.1 or later. Since this is not a cloud service, administrators must manually update their GitLab installations to remediate this vulnerability.
Description
A missing authorization vulnerability in GitLab CE/EE allows attackers with access to a victim's Personal Access Token (PAT) to escalate privileges. This affects GitLab versions from 8.12 up to but not including 17.4.5, versions 17.5.0 up to but not including 17.5.3, and versions 17.6.0 up to but not including 17.6.1. A patch is available to address this issue.