CVE-2025-2246: GitLab · Missing Authorization
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.3.1 : update gitlab when convenient.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.3.1, 18.2.5, 18.1.5
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade gitlab to 18.3.1, 18.2.5 or 18.1.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading GitLab CE/EE to version 18.1.5 or later for the 18.1 branch, 18.2.5 or later for the 18.2 branch, and 18.3.1 or later for the 18.3 branch. Since this is not a cloud service, users must manually update their installations to remediate this vulnerability.
Description
A missing authorization vulnerability in GitLab CE/EE versions before 18.1.5, 18.2 before 18.2.5, and 18.3 before 18.3.1 allows unauthenticated users to access sensitive manual CI/CD variables via the GraphQL API. This issue has been addressed in the specified patched versions.