Skip to main content
CVE-2026-44243VulnerabilityPublished Updated

Mistral vibe: GitPython reference APIs has a path traversal vulnerability that allows arbitrary file write and delete

Affects mistral-vibeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-44243· High 7.8

Public exploit available · CVSS 7.8 High : upgrade to 2.18.0 or 2.9.0 as a priority.

Data as of 30 Oct 2026, 08:03 UTC

CVSS 4.0 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.18.0, 2.9.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mistral-vibe to 2.18.0 or 2.9.0.

Affected software

ProductAffectedFixed in
Homebrewmistral-vibepkg:brew/mistral-vibeOther threatsAffected
  • >=2.1.0 <2.9.0
  • >=2.10.0 <2.18.0
Fixed in
  • 2.9.0
  • 2.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython versions 2.9.0 and 2.18.0 and later. The recommended mitigation is to upgrade to these fixed versions. The fix involves validating reference paths before write, rename, and delete operations to ensure they do not escape the repository boundary. Applications should ensure they do not pass untrusted input to GitPython reference APIs or upgrade to patched versions to prevent exploitation.

Description

GitPython versions up to 3.1.46 and the current main branch (3.1.47 locally) contain a path traversal vulnerability in reference APIs that allows attackers to write, overwrite, move, or delete files outside the repository's .git directory. This occurs due to insufficient validation of reference paths during write, rename, and delete operations. Exploitation requires local access to supply crafted reference paths through applications using GitPython. The vulnerability can lead to high integrity and availability impacts by corrupting or deleting arbitrary files accessible to the process.

References

Community reviews

Loading reviews…