Skip to main content
VulnerabilityPublished

CVE-2026-115355: Mistune · Path Traversal and XSS in Include directive

Affects jupyterlabSource GCVE Database

0
Authoritative record:CVE-2026-115355· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 4.6.1 soon.

Data as of 27 Oct 2026, 06:57 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.6.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade jupyterlab to 4.6.1.

Affected software

ProductAffectedFixed in
Homebrewjupyterlabpkg:brew/jupyterlabOther threatsAffected
  • >=3.4.7 <4.6.1
Fixed in
  • 4.6.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in JupyterLab version 4.6.1. Users should upgrade to this version or later to remediate the vulnerability. Since the Include plugin must be explicitly enabled to be exploitable, disabling this plugin if not needed can reduce risk. No other vendor advisories indicate alternative mitigations or that the issue is already mitigated.

Description

A vulnerability in the Include directive of Mistune (used in JupyterLab) allows path traversal via '../' sequences to read arbitrary files outside the intended source directory. Additionally, error messages and included file contents are rendered without HTML escaping, enabling cross-site scripting (XSS) even when escaping is enabled. The Include plugin must be explicitly enabled to be exploitable. This issue affects JupyterLab versions from 3.4.7 up to but not including 4.6.1 and is fixed in version 4.6.1.

References

Community reviews

Loading reviews…