Skip to main content
VulnerabilityPublished

CVE-2026-116690: MLflow vulnerable to arbitrary file read on unauthenticated servers via prompt model version source

Affects mlflowSource GCVE Database

0
Authoritative record:CVE-2026-116690· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 3.17.0 soon.

Data as of 27 Oct 2026, 22:26 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.17.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mlflow to 3.17.0.

Affected software

ProductAffectedFixed in
PyPImlflowAffected
  • >=3.10.0 <3.17.0
Fixed in
  • 3.17.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in MLflow version 3.17.0. Users should upgrade affected MLflow servers from versions 3.10.0 through 3.16.1 to 3.17.0 or later. The fix enforces stricter validation of prompt model version sources, allowing only MLflow's own placeholder sources and requiring the prompt tag to be true. Until upgraded, avoid running MLflow tracking servers without authentication or restrict access to trusted users only.

Description

MLflow tracking servers running without authentication or with basic authentication are vulnerable to an arbitrary file read vulnerability via crafted model versions tagged as prompts with schemeless local paths. This allows remote attackers to read arbitrary files on the server filesystem with the privileges of the MLflow server process. The vulnerability affects MLflow versions 3.10.0 through 3.16.1 and is fixed in version 3.17.0.

References

Community reviews

Loading reviews…