Skip to main content
VulnerabilityPublished

CVE-2025-14087: glib2 security update

Affects glib2Source GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-14087· Medium 5.6

Not known to be exploited · CVSS 5.6 Medium : upgrade to 2.68.4-18.el9_7.2 when convenient.

Data as of 27 Oct 2026, 00:28 UTC

CVSS 3.1 base score
5.6Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.68.4-18.el9_7.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 2.68.4-18.el9_7.2.

Affected software

ProductAffectedFixed in
AlmaLinux 9glib2Affected
  • <2.68.4-18.el9_7.2
Fixed in
  • 2.68.4-18.el9_7.2
AlmaLinux 9glib2-develAffected
  • <2.68.4-18.el9_7.2
Fixed in
  • 2.68.4-18.el9_7.2
AlmaLinux 9glib2-docAffected
  • <2.68.4-18.el9_7.2
Fixed in
  • 2.68.4-18.el9_7.2
AlmaLinux 9glib2-staticAffected
  • <2.68.4-18.el9_7.2
Fixed in
  • 2.68.4-18.el9_7.2
AlmaLinux 9glib2-testsAffected
  • <2.68.4-18.el9_7.2
Fixed in
  • 2.68.4-18.el9_7.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in glib2 version 2.68.4-18.el9_7.2 and later. Users should apply the official update provided by Red Hat to remediate these vulnerabilities. No additional mitigation steps are indicated by the vendor advisory.

Description

A security update for glib2 addresses a buffer underflow vulnerability in the GVariant parser that leads to heap corruption (CVE-2025-14087), as well as an integer overflow in GLib GIO attribute escaping causing a heap buffer overflow (CVE-2025-14512). These issues affect versions of glib2 prior to 2.68.4-18.el9_7.2. The update is rated as having a moderate security impact by Red Hat.

References

Community reviews

Loading reviews…