Skip to main content
VulnerabilityPublished

CVE-2026-4271: Moderate · libsoup3 security update

Affects libsoup3-docSource GCVE Database

0
Authoritative record:CVE-2026-4271· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.6.5-3.el10_1.11 when convenient.

Data as of 27 Oct 2026, 00:28 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.6.5-3.el10_1.11
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux libsoup3-doc package to 3.6.5-3.el10_1.11.

Affected software

ProductAffectedFixed in
AlmaLinux 10libsoup3-docAffected
  • <3.6.5-3.el10_1.11
Fixed in
  • 3.6.5-3.el10_1.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in libsoup3 version 3.6.5-3.el10_1.11. Users should apply this update promptly to remediate the issue. Red Hat provides official guidance on applying the update in their advisory. No additional mitigation steps are indicated.

Description

Libsoup3, a C-based HTTP library used in GNOME applications, contains a denial of service vulnerability due to a use-after-free flaw in its HTTP/2 server implementation (CVE-2026-4271). This issue could cause service disruption. A security update addressing this vulnerability is available in version 3.6.5-3.el10_1.11. The vulnerability is rated with moderate severity by Red Hat. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…