CVE-2026-34743: xz security update
Affects xzSource GCVE Database
Not known to be exploited · CVSS 1.7 Low : upgrade to 5.2.5-8.el9_8.1 when convenient.
Data as of 26 Oct 2026, 20:29 UTC
- Patch
- Available – fixed in 5.2.5-8.el9_8.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the AlmaLinux to 5.2.5-8.el9_8.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 9xz | Affected
| Fixed in
|
| AlmaLinux 9xz-devel | Affected
| Fixed in
|
| AlmaLinux 9xz-libs | Affected
| Fixed in
|
| AlmaLinux 9xz-lzma-compat | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of xz (5.2.5-8.el9_8.1) is available from Red Hat. Users should apply this update to remediate the vulnerability. No additional mitigation steps are required beyond applying the official patch.
Description
A denial of service vulnerability exists in XZ Utils due to a buffer overflow in index decoding. This flaw affects versions of the xz utility prior to 5.2.5-8.el9_8.1. The issue has been rated as moderate severity by Red Hat and is fixed in version 5.2.5-8.el9_8.1.