Skip to main content
VulnerabilityPublished Updated

CVE-2024-7553: Mongodb · Accessing Untrusted Directory May Allow Local Privilege Escalation

Affects mongodbSource GCVE Database

0

Not known to be exploited · fixed in 7.0.12 : patch mongodb soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.12, 6.0.16, 5.0.27

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mongodb to 7.0.12, 6.0.16 or 5.0.27.

Affected software

ProductAffectedFixed in
Bitnamimongodbpkg:bitnami/mongodbOther threatsAffected
  • >=5.0.0 <5.0.27
  • >=6.0.0 <6.0.16
  • >=7.0.0 <7.0.12
Fixed in
  • 5.0.27
  • 6.0.16
  • 7.0.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches provided by MongoDB to upgrade to versions 5.0.27 or later, 6.0.16 or later, and 7.0.12 or later for the MongoDB Server. Similarly, update MongoDB C Driver to version 1.26.2 or later and PHP Driver to version 1.18.1 or later. These updates fix the improper validation of files from untrusted directories. No additional mitigation is required if these patches are applied.

Description

A local privilege escalation vulnerability exists in MongoDB Server on Windows due to improper validation of files loaded from untrusted local directories. This flaw allows an attacker with local access to cause the application to execute arbitrary behavior based on malicious file contents. The issue affects MongoDB Server versions prior to 5.0.27, 6.0.16, and 7.0.12 on Windows, as well as certain MongoDB C and PHP driver versions. A fix is available for the affected versions.

References

Community reviews

Loading reviews…