CVE-2024-6375: Mongodb · Missing authorization check may lead to shard key refinement
Affects mongodbSource GCVE Database
Not known to be exploited · fixed in 7.0.3 : update mongodb when convenient.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.3, 6.0.11, 5.0.22
Exploitation evidence
Disclosed: evidence found.
CVE published 4 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade mongodb to 7.0.3, 6.0.11 or 5.0.22.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimongodbpkg:bitnami/mongodbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade MongoDB Server to versions 5.0.22 or later, 6.0.11 or later, or 7.0.3 or later to remediate the issue. Applying these official fixes will prevent unauthorized execution of the shard key refinement command and mitigate the associated risks.
Description
A missing authorization check in a MongoDB command for refining a collection shard key can cause the command to run directly on a shard. This may degrade query performance or reveal chunk boundaries through timing side channels. The vulnerability affects MongoDB Server versions 5.0 prior to 5.0.22, 6.0 prior to 6.0.11, and 7.0 prior to 7.0.3. A patch is available to address this issue.