Mongoose: Prior to 7.23, the built-in TLS certificate parser selected by MG_TLS_BUILTIN fails to verify that a
Affects mongooseSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 7.23 : patch mongoose soon.
Data as of 29 Oct 2026, 01:43 UTC
- Patch
- Available – fixed in 7.23
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10mongoosepkg:deb/ubuntu/mongoose?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Mongoose to version 7.23 or later, where this vulnerability is fixed. No other mitigations are indicated.
Description
Mongoose versions prior to 7.23 contain a vulnerability in the built-in TLS certificate parser (MG_TLS_BUILTIN) where it fails to properly verify long-form DER element lengths within certificates. This flaw allows a malicious TLS server or client to cause an out-of-bounds read during the TLS handshake, leading to a denial of service. The issue is resolved in version 7.23.