CVE-2025-26525: Moodle · Arbitrary file read risk through pdfTeX
Affects moodleSource GCVE Database
Not known to be exploited · fixed in 4.5.2 : patch moodle soon.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.5.2, 4.4.6, 4.3.10 +1
Exploitation evidence
Disclosed: evidence found.
CVE published 10 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade moodle to 4.5.2, 4.4.6, 4.3.10 or 4.1.16.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimoodlepkg:bitnami/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied to affected Moodle versions. Administrators should update to Moodle versions 4.1.16 or later, 4.3.10 or later, 4.4.6 or later, or 4.5.2 or later as appropriate. Refer to the official Moodle Git commit MDL-84136 for the patch details.
Description
A vulnerability in Moodle's TeX notation filter allows arbitrary file reading on systems where pdfTeX is available, such as those with TeX Live installed. This occurs due to insufficient sanitization of input. Multiple Moodle versions are affected, and patches have been released to address the issue.