Skip to main content
CVE-2024-34003VulnerabilityPublished Updated

CVE-2024-34003: moodle · authenticated LFI risk in some misconfigured shared hosting environments via modified mod_workshop backup

Affects moodleSource GCVE Database

0

Not known to be exploited · fixed in 4.3.4 : update moodle when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.4, 4.2.7, 4.1.10

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade moodle to 4.3.4, 4.2.7 or 4.1.10.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • <4.1.10
  • >=4.2.0 <4.2.7
  • >=4.3.0 <4.3.4
Fixed in
  • 4.1.10
  • 4.2.7
  • 4.3.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability and should be applied to affected Moodle versions. Administrators should ensure that their hosting environments are properly configured to isolate users and prevent unauthorized access to other users' content. Applying the official Moodle updates that fix this issue will mitigate the risk. No additional vendor advisory content contradicts these recommendations.

Description

CVE-2024-34003 is a medium severity vulnerability in Moodle affecting certain versions prior to 4.1.10, between 4.2.0 and 4.2.7, and between 4.3.0 and 4.3.4. It allows an authenticated Moodle user with permissions to restore workshop modules and direct web server access outside the Moodle webroot in a misconfigured shared hosting environment to perform a local file inclusion (LFI). This vulnerability arises only if the hosting environment is misconfigured to permit access to other users' content. A patch is available to address this issue.

References

Community reviews

Loading reviews…