Skip to main content
CVE-2024-34002VulnerabilityPublished Updated

CVE-2024-34002: moodle · authenticated LFI risk in some misconfigured shared hosting environments via modified mod_feedback backup

Affects moodleSource GCVE Database

0

Not known to be exploited · fixed in 4.3.4 : update moodle when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.4, 4.2.7, 4.1.10

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade moodle to 4.3.4, 4.2.7 or 4.1.10.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • <4.1.10
  • >=4.2.0 <4.2.7
  • >=4.3.0 <4.3.4
Fixed in
  • 4.1.10
  • 4.2.7
  • 4.3.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade Moodle to versions 4.1.10 or later, 4.2.7 or later, or 4.3.4 or later as appropriate. Additionally, ensure that shared hosting environments are properly configured to prevent unauthorized access to other users' content and restrict direct web server access outside the Moodle webroot. These measures will mitigate the risk of exploitation.

Description

CVE-2024-34002 is a medium severity vulnerability affecting Moodle in certain misconfigured shared hosting environments. It allows an authenticated Moodle user with permissions to restore feedback modules and direct web server access outside the Moodle webroot to perform a local file inclusion (LFI) attack. This issue arises only if the hosting environment is misconfigured to permit access to other users' content. Patches are available for affected versions to address this vulnerability.

References

Community reviews

Loading reviews…