Skip to main content
CVE-2024-34001VulnerabilityPublished Updated

CVE-2024-34001: moodle · CSRF risk in admin preset tool management of presets

Affects moodleSource GCVE Database

0

Not known to be exploited · fixed in 4.3.4 : patch moodle soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.4, 4.2.7, 4.1.10

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade moodle to 4.3.4, 4.2.7 or 4.1.10.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • <4.1.10
  • >=4.2.0 <4.2.7
  • >=4.3.0 <4.3.4
Fixed in
  • 4.1.10
  • 4.2.7
  • 4.3.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Administrators should update affected Moodle installations to versions 4.1.10 or later, 4.2.7 or later, and 4.3.4 or later as applicable to their version line. Applying these updates will mitigate the CSRF risk in the admin preset tool management.

Description

A Cross-Site Request Forgery (CSRF) vulnerability exists in the admin preset tool management of Moodle. The affected actions do not include the necessary token to prevent CSRF attacks, allowing unauthorized commands to be potentially executed by authenticated administrators. This vulnerability affects multiple Moodle versions prior to their respective fixed releases. A patch is available to address this issue.

References

Community reviews

Loading reviews…