Skip to main content
CVE-2024-34008VulnerabilityPublished Updated

CVE-2024-34008: moodle · CSRF risk in analytics management of models

Affects moodleSource GCVE Database

0

Not known to be exploited : upgrade to 4.3.4 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade moodle to 4.3.4.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • >=4.0.0 <4.3.4
Fixed in
  • 4.3.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Administrators should update Moodle to version 4.3.4 or later to apply the official fix. If you cannot patch yet, administrators should be cautious with access to the analytics management interface and consider additional protective measures if feasible.

Description

A Cross-Site Request Forgery (CSRF) vulnerability exists in the admin management of analytics models in Moodle. The affected actions lack the necessary CSRF token protection, allowing unauthorized commands to be potentially executed by an attacker. This vulnerability affects Moodle versions from 4.0.0 up to but not including 4.3.4. A patch is available to address this issue.

References

Community reviews

Loading reviews…