CVE-2024-38276: moodle · CSRF risks due to misuse of confirm_sesskey
Affects moodleSource GCVE Database
Not known to be exploited · fixed in 4.4.1 : patch moodle soon.
Data as of 26 Oct 2026, 12:29 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.1, 4.3.5, 4.2.8 +1
Exploitation evidence
Disclosed: evidence found.
CVE published 9 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade moodle to 4.4.1, 4.3.5, 4.2.8 or 4.1.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimoodlepkg:bitnami/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade Moodle to versions 4.1.10 or later, 4.2.8 or later, 4.3.5 or later, or 4.4.1 or later to remediate the issue. Applying these updates will correct the confirm_sesskey token validation and eliminate the CSRF risks.
Description
Multiple cross-site request forgery (CSRF) risks exist in Moodle due to incorrect checks of the confirm_sesskey token. This vulnerability affects several Moodle versions prior to specific patched releases. The issue allows unauthorized actions to be performed by attackers exploiting improper CSRF token validation.
References
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/F7AZYR7EXV6E5SQE2GYTNQE3NOENJCQ6/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GHTIX55J4Q4LEOMLNEA4OZSWVEENQX7E/ (opens in a new tab)
- moodle.org/mod/forum/discuss.php?d=459501 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-38276 (opens in a new tab)