Skip to main content
CVE-2025-26531VulnerabilityPublished Updated

CVE-2025-26531: Moodle · IDOR in badges allows disabling of arbitrary badges

Affects moodleSource GCVE Database

0

Not known to be exploited · fixed in 4.5.2 : update moodle when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.2, 4.4.6, 4.3.10 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade moodle to 4.5.2, 4.4.6, 4.3.10 or 4.1.16.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • >=4.1.0 <4.1.16
  • >=4.3.0 <4.3.10
  • >=4.4.0 <4.4.6
  • >=4.5.0 <4.5.2
Fixed in
  • 4.1.16
  • 4.3.10
  • 4.4.6
  • 4.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patch provided by Moodle as referenced in the commit MDL-84239. Upgrading affected Moodle instances to versions 4.1.16 or later, 4.3.10 or later, 4.4.6 or later, and 4.5.2 or later will remediate this vulnerability.

Description

A vulnerability in Moodle allows users to disable badges they should not have permission to access due to insufficient capability checks. This issue affects multiple Moodle versions and has been assigned CVE-2025-26531. A patch is available to address this issue.

References

Community reviews

Loading reviews…