Skip to main content
CVE-2024-34007VulnerabilityPublished Updated

CVE-2024-34007: moodle · logout CSRF in admin/tool/mfa/auth.php

Affects moodleSource GCVE Database

0

Not known to be exploited : upgrade to 4.3.4 soon.

Data as of 26 Oct 2026, 06:26 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade moodle to 4.3.4.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • >=4.3.0 <4.3.4
Fixed in
  • 4.3.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade Moodle to version 4.3.4 or later where the CSRF token protection for the logout option in MFA is implemented. No additional mitigation steps are indicated by the vendor advisory.

Description

A Cross-Site Request Forgery (CSRF) vulnerability exists in the logout option within the Multi-Factor Authentication (MFA) component of Moodle. Specifically, the logout function in admin/tool/mfa/auth.php lacks the necessary CSRF token, which could allow users to be logged out unintentionally via CSRF attacks. This affects Moodle versions from 4.3.0 up to but not including 4.3.4. A patch is available to address this issue.

References

Community reviews

Loading reviews…