Skip to main content
CVE-2025-26527VulnerabilityPublished Updated

CVE-2025-26527: Moodle · Non-searchable tags can still be discovered on the tag search page and in the tags block

Affects moodleSource GCVE Database

0

Not known to be exploited · fixed in 4.5.2 : update moodle when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.2, 4.4.6, 4.3.10 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade moodle to 4.5.2, 4.4.6, 4.3.10 or 4.1.16.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • >=4.1.0 <4.1.16
  • >=4.3.0 <4.3.10
  • >=4.4.0 <4.4.6
  • >=4.5.0 <4.5.2
Fixed in
  • 4.1.16
  • 4.3.10
  • 4.4.6
  • 4.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patch provided by Moodle as referenced in the commit MDL-83941. Upgrading affected Moodle versions to 4.1.16 or later, 4.3.10 or later, 4.4.6 or later, or 4.5.2 or later will remediate this vulnerability.

Description

A vulnerability in Moodle allows tags that are not intended to be visible to users to still be discovered through the tag search page or the tags block. This issue affects multiple Moodle versions prior to specific patched releases. The vulnerability has been assigned CVE-2025-26527 and is rated medium severity. A patch is available to address this issue.

References

Community reviews

Loading reviews…