CVE-2024-38277: QR login key and auto-login key for the Moodle mobile app should be generated as separate keys
Affects moodleSource GCVE Database
Not known to be exploited · fixed in 4.4.1 : update moodle when convenient.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.1, 4.3.5, 4.2.8 +1
Exploitation evidence
Disclosed: evidence found.
CVE published 8 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade moodle to 4.4.1, 4.3.5, 4.2.8 or 4.1.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimoodlepkg:bitnami/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade to Moodle versions 4.1.11 or later, 4.2.8 or later, 4.3.5 or later, or 4.4.1 or later to ensure that QR login keys and auto-login keys are generated separately. Applying the official patch resolves the issue.
Description
CVE-2024-38277 is a vulnerability in Moodle where the QR login key and the auto-login key for the Moodle mobile app are not generated as separate unique keys. This allows the same key to be used interchangeably between QR login and auto-login, which is not intended behavior. The issue affects multiple Moodle versions prior to specific patch releases. A patch is available to address this issue.
References
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/F7AZYR7EXV6E5SQE2GYTNQE3NOENJCQ6/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GHTIX55J4Q4LEOMLNEA4OZSWVEENQX7E/ (opens in a new tab)
- moodle.org/mod/forum/discuss.php?d=459502 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-38277 (opens in a new tab)