CVE-2025-26530: Moodle · Reflected XSS via question bank filter
Affects moodleSource GCVE Database
Not known to be exploited · fixed in 4.5.2 : patch moodle soon.
Data as of 26 Oct 2026, 13:47 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.5.2, 4.4.6, 4.3.10
Exploitation evidence
Disclosed: evidence found.
CVE published 12 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade moodle to 4.5.2, 4.4.6 or 4.3.10.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimoodlepkg:bitnami/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied to affected Moodle installations. The fix is included in versions 4.3.10 and later, 4.4.6 and later, and 4.5.2 and later. Administrators should update to these versions to remediate the vulnerability.
Description
The question bank filter required additional sanitizing to prevent a reflected XSS risk.