CVE-2025-26533: Moodle · SQL injection risk in course search module list filter
Affects moodleSource GCVE Database
Not known to be exploited · fixed in 4.5.2 : patch moodle as a priority.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.5.2, 4.4.6, 4.3.10 +1
Exploitation evidence
Disclosed: evidence found.
CVE published 7 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade moodle to 4.5.2, 4.4.6, 4.3.10 or 4.1.16.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimoodlepkg:bitnami/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade affected Moodle installations to versions 4.1.16 or later, 4.3.10 or later, 4.4.6 or later, or 4.5.2 or later to remediate the issue. Refer to the official Moodle Git commit MDL-84271 for details on the fix.
Description
An SQL injection vulnerability exists in the course search module list filter of Moodle. This flaw allows an attacker to manipulate SQL queries, potentially compromising the database. The issue affects multiple Moodle versions prior to specific patched releases. A patch is available to address this vulnerability.