Skip to main content
CVE-2025-26528VulnerabilityPublished Updated

CVE-2025-26528: Moodle · Stored XSS in ddimageortext question type

Affects moodleSource GCVE Database

0

Not known to be exploited · fixed in 4.5.2 : update moodle when convenient.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.2, 4.4.6, 4.3.10 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade moodle to 4.5.2, 4.4.6, 4.3.10 or 4.1.16.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • >=4.1.0 <4.1.16
  • >=4.3.0 <4.3.10
  • >=4.4.0 <4.4.6
  • >=4.5.0 <4.5.2
Fixed in
  • 4.1.16
  • 4.3.10
  • 4.4.6
  • 4.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch addressing this stored XSS vulnerability is available and should be applied. The affected Moodle versions are those prior to 4.1.16, 4.3.10, 4.4.6, and 4.5.2 respectively. Administrators should upgrade to these fixed versions or later to remediate the issue.

Description

A stored cross-site scripting (XSS) vulnerability exists in the drag-and-drop onto image (ddimageortext) question type in Moodle. This issue arises due to insufficient sanitization of input, allowing malicious scripts to be stored and potentially executed when the content is viewed. The vulnerability affects multiple Moodle versions prior to their respective patches. A fix has been made available to address this sanitization deficiency.

References

Community reviews

Loading reviews…