Skip to main content
CVE-2024-34000VulnerabilityPublished Updated

CVE-2024-34000: moodle · stored XSS in lesson overview report via user ID number

Affects moodleSource GCVE Database

0

Not known to be exploited · fixed in 4.3.4 : update moodle when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.3.4, 4.2.7, 4.1.10

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade moodle to 4.3.4, 4.2.7 or 4.1.10.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • <4.1.10
  • >=4.2.0 <4.2.7
  • >=4.3.0 <4.3.4
Fixed in
  • 4.1.10
  • 4.2.7
  • 4.3.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade affected Moodle installations to versions 4.1.10 or later, 4.2.7 or later, or 4.3.4 or later to remediate the issue. Applying these official fixes will prevent exploitation of the stored XSS vulnerability.

Description

A stored cross-site scripting (XSS) vulnerability exists in Moodle's lesson overview report due to insufficient sanitization of user ID numbers. This flaw allows malicious scripts to be stored and potentially executed when the lesson overview report is viewed. The vulnerability affects multiple Moodle versions prior to specific patched releases. A patch is available to address this issue. No known exploits are currently reported in the wild.

References

Community reviews

Loading reviews…