Skip to main content
CVE-2025-26532VulnerabilityPublished Updated

CVE-2025-26532: Moodle · Teachers can evade trusttext config when restoring glossary entries

Affects moodleSource GCVE Database

0

Not known to be exploited · fixed in 4.5.2 : update moodle when convenient.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.2, 4.4.6, 4.3.10 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade moodle to 4.5.2, 4.4.6, 4.3.10 or 4.1.16.

Affected software

ProductAffectedFixed in
Bitnamimoodlepkg:bitnami/moodleOther threatsAffected
  • >=4.1.0 <4.1.16
  • >=4.3.0 <4.3.10
  • >=4.4.0 <4.4.6
  • >=4.5.0 <4.5.2
Fixed in
  • 4.1.16
  • 4.3.10
  • 4.4.6
  • 4.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected Moodle versions. The fix ensures that trusttext checks are properly enforced during glossary entry restoration. Administrators should update Moodle to versions 4.1.16 or later, 4.3.10 or later, 4.4.6 or later, or 4.5.2 or later to remediate this vulnerability.

Description

A vulnerability in Moodle allows teachers to bypass the trusttext configuration when restoring glossary entries. This issue occurs because additional checks were needed to ensure that trusttext is properly applied during the restoration process. The vulnerability affects multiple Moodle versions prior to their respective patches. A fix is available to address this issue.

References

Community reviews

Loading reviews…