CVE-2024-33999: moodle · unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php
Affects moodleSource GCVE Database
Not known to be exploited : upgrade to 4.3.4 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.3.4
Exploitation evidence
Disclosed: evidence found.
CVE published 31 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade moodle to 4.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimoodlepkg:bitnami/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade Moodle to version 4.3.4 or later to ensure the unsafe use of HTTP_REFERER is properly sanitized. No additional mitigation steps are indicated beyond applying the official fix.
Description
A critical vulnerability in Moodle versions 4.3.0 through before 4.3.4 involves unsafe direct use of the HTTP_REFERER server variable in the multi-factor authentication (MFA) admin tool. The referrer URL was used without sufficient sanitization, potentially allowing security issues related to untrusted input. A patch is available to address this issue.