CVE-2024-34006: moodle · unsanitized HTML in site log for config_log_created
Affects moodleSource GCVE Database
Not known to be exploited · fixed in 4.3.4 : update moodle when convenient.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.3.4, 4.2.7, 4.1.10
Exploitation evidence
Disclosed: evidence found.
CVE published 31 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade moodle to 4.3.4, 4.2.7 or 4.1.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimoodlepkg:bitnami/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade Moodle to versions 4.1.10 or later, 4.2.7 or later, or 4.3.4 or later to remediate the issue. No additional mitigation steps are indicated.
Description
CVE-2024-34006 is a vulnerability in Moodle where the site log report did not properly encode event descriptions, allowing HTML content to be rendered instead of displayed as plaintext. This issue affects multiple Moodle versions prior to specific patched releases. The vulnerability has a medium severity rating and a patch is available to address the issue.