Skip to main content
VulnerabilityPublished Updated

CVE-2026-117984: Mozjs52 · Incorrect boundary conditions in the Layout: Scrolling and Overflow component

Affects mozjs52Source GCVE Database

0
Compare
Authoritative record:CVE-2026-117984· High 8.8

Not known to be exploited · CVSS 8.8 High.

Data as of 7 Nov 2026, 02:48 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.18.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSmozjs102pkg:deb/ubuntu/mozjs102?arch=source&distro=nobleOther threatsAffected
  • =102.15.1-1
  • =102.15.1-3ubuntu2
Fixed in–
Ubuntu 24.04 LTSmozjs115pkg:deb/ubuntu/mozjs115?arch=source&distro=nobleOther threatsAffected
  • 115.3.0-0ubuntu1 – 115.10.0-1
9 affected builds
Fixed in–
Ubuntu 22.04 LTSmozjs102pkg:deb/ubuntu/mozjs102?arch=source&distro=jammyOther threatsAffected
  • 102.11.0-0ubuntu0.22.04.1 – 102.15.1-0ubuntu0.22.04.1
4 affected builds
Fixed in–
Ubuntu 22.04 LTSmozjs78pkg:deb/ubuntu/mozjs78?arch=source&distro=jammyOther threatsAffected
  • =78.13.0-1
  • =78.15.0-2
  • =78.15.0-4ubuntu1
Fixed in–
Ubuntu 22.04 LTSmozjs91pkg:deb/ubuntu/mozjs91?arch=source&distro=jammyOther threatsAffected
  • 91.5.1-0ubuntu1 – 91.10.0-0ubuntu1
5 affected builds
Fixed in–
Ubuntu 22.04 LTSthunderbirdpkg:deb/ubuntu/thunderbird?arch=source&distro=jammyOther threatsAffected
  • 1:91.1.2+build1-0ubuntu1 – 1:140.7.1+build1-0ubuntu0.22.04.1
39 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official fixes provided by Mozilla by upgrading to Firefox 159, Firefox ESR 153.6, Thunderbird 159, or Thunderbird 153.6 or later. These versions contain the patch that resolves the incorrect boundary condition issue. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-117984 is a high-severity vulnerability in the mozjs52 JavaScript engine related to incorrect boundary conditions in the Layout: Scrolling and Overflow component. This flaw could lead to significant impacts on confidentiality, integrity, and availability. The issue was fixed in Firefox 159, Firefox ESR 153.6, Thunderbird 159, and Thunderbird 153.6.

References

Community reviews

Loading reviews…