Skip to main content
VulnerabilityPublished Updated

CVE-2026-104874: Reference leak in CIMultiDict/MultiDict items-view union and subtraction

Affects parsedmarcSource GCVE Database

0
Compare
Authoritative record:CVE-2026-104874· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 11.0.3 or 9.9.0 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.0.3, 9.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade parsedmarc to 11.0.3 or 9.9.0.

Affected software

ProductAffectedFixed in
Homebrewparsedmarcpkg:brew/parsedmarcOther threatsAffected
  • >=8.18.7 <9.9.0
  • >=9.11.0 <11.0.3
Fixed in
  • 9.9.0
  • 11.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. The vulnerability is fixed in multidict versions 9.9.0 and 11.0.3. Upgrading to these or later versions will remediate the issue. No additional mitigations are required as the fix addresses the root cause of the reference leak.

Description

A reference leak vulnerability exists in the items-view union and subtraction operators of aio-libs/multidict versions 6.7.0 through 6.9.0. This flaw allows a remote client to cause unbounded memory growth by leaking key-identity and value objects during certain set operations on dictionary views. The leak occurs because the code fails to release new strong references created during iteration, leading to unreclaimable memory until the process is terminated. This issue affects servers using aio-libs that build these views over attacker-controlled HTTP headers or query strings.

References

Community reviews

Loading reviews…