Skip to main content
VulnerabilityPublished

CVE-2026-17032: Multiple Supsystic Pro plugins were distributed with malicious code through the vendor's compromised update server, allowing unauthenticated

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-17032· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.7.0 as a priority.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.7.0, 2.11.1, 1.10.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by WPScan

    , 13 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 21 hours after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade google-maps-easy-pro to 1.7.0; supsystic-gallery-pro to 2.11.1; tables-generator-pro to 1.10.1.

Affected software

ProductAffectedFixed in
google-maps-easy-proAffected
  • >=1.6.9 <1.7.0
Fixed in
  • 1.7.0
supsystic-gallery-proAffected
  • >=2.10.9 <2.11.1
Fixed in
  • 2.11.1
tables-generator-proAffected
  • >=1.9.20 <1.10.1
Fixed in
  • 1.10.1

AI-suggested

Until an official fix or update is provided, users should consider disabling affected plugins and monitoring official vendor communications for updates. Due to the nature of the compromise involving the vendor's update server, remediation may require vendor intervention to secure the update infrastructure and release clean plugin versions.

Description

Multiple Supsystic Pro plugins were distributed containing malicious code due to a compromise of the vendor's update server. This vulnerability allows unauthenticated attackers to deploy a second-stage payload that can exfiltrate credentials and other sensitive data, as well as gain full control over affected websites. The issue is rated critical with a CVSS score of 9.8, indicating high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…