Skip to main content
CVE-2026-119714VulnerabilityPublished

My Calendar WordPress plugin 3.8.8 before 3.8.11 contains a shortcode injection vulnerability that allows

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119714· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 3.8.11 when convenient.

Data as of 30 Oct 2026, 20:19 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.16.5
CNACVSS 4.06.9
Patch
Available – fixed in 3.8.11
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade My Calendar (WordPress plugin) to 3.8.11.

Affected software

ProductAffectedFixed in
joedolsonMy Calendar - Accessible Event ManagerAffected
  • >=3.8.8 <3.8.11
Fixed in
  • 3.8.11

AI-suggested

A fixed version of the plugin is available starting from version 3.8.11. Users should upgrade to version 3.8.11 or later to remediate this vulnerability. Until patched, avoid exposing the affected parameter to untrusted input or restrict access to the affected functionality if possible.

Description

The My Calendar WordPress plugin versions 3.8.8 up to but not including 3.8.11 contain a shortcode injection vulnerability. This flaw allows unauthenticated attackers to execute registered shortcodes via the 'mcs' search parameter. The vulnerability arises because the 'mcs' parameter value is passed to the mc_search_results() function without proper bracket encoding before the do_shortcode function executes, enabling shortcode execution on any page or post. This can lead to content injection and spoofing.

References

Community reviews

Loading reviews…