Skip to main content
CVE-2026-118645VulnerabilityPublished

n8n before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 contains a filter injection vulnerability in the

Affects n8nSource GCVE Database

0
Authoritative record:CVE-2026-118645· High 7.0

Not known to be exploited · CVSS 7.0 High · fixed in 2.44.1 : patch n8n soon.

Data as of 28 Oct 2026, 22:27 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
Affects
n8n before 1.123.85
Patch
Available – fixed in 2.44.1, 2.43.5, 1.123.85
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade n8n to 2.44.1, 2.43.5 or 1.123.85.

Affected software

ProductAffectedFixed in
npmn8npkg:npm/n8nOther threatsAffected
  • <1.123.85
  • >=2.0.0 <2.43.5
  • >=2.44.0 <2.44.1
Fixed in
  • 1.123.85
  • 2.43.5
  • 2.44.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability affects n8n versions before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1. Users should upgrade to version 1.123.85 or later, 2.43.5 or later in the 2.x series, or 2.44.1 or later in the 2.44.x series to remediate this issue. No vendor advisory or patch links were provided, so confirm patch availability from official n8n sources before applying updates.

Description

A filter injection vulnerability exists in the Quick Base node of n8n versions before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1. This flaw allows attackers to supply untrusted input, such as webhook data, that is sent as raw query text to the Quick Base API. Exploitation can cause the 'Get Many' operation to return all records or the 'Delete' operation to remove all records accessible by the workflow credentials.

References

Community reviews

Loading reviews…