n8n before 2.41.4 and 2.42.x before 2.42.1 contains a prototype pollution vulnerability that allows low-privileged
Affects n8nSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2.42.1 or 2.41.4 soon.
Data as of 28 Oct 2026, 22:14 UTC
- Affects
- n8n before 2.41.4
- Patch
- Available – fixed in 2.42.1, 2.41.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade n8n-io/n8n to 2.42.1 or 2.41.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmn8n-io/n8npkg:npm/n8n-io/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in n8n version 2.41.4 and in 2.42.x starting from 2.42.1. Users should upgrade to these versions or later to remediate the vulnerability. No other mitigation guidance is provided in the input data.
Description
A prototype pollution vulnerability exists in n8n versions before 2.41.4 and in 2.42.x versions before 2.42.1. This flaw allows low-privileged users to manipulate built-in object behavior by saving workflows with specially crafted connection keys such as __proto__. The vulnerability causes server errors during the periodic history compaction task, leading to login failures and write operation disruptions.