Skip to main content
VulnerabilityPublished Updated

CVE-2025-34298: Nagios Log Server versions prior to 2024R1.3.2 contain a privilege escalation vulnerability in the

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-34298· High 8.7

Not known to be exploited · CVSS 8.7 High · fixed in 2024R1.3.2 : patch affected systems soon.

Data as of 4 Nov 2026, 18:33 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2024R1.3.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

AI-suggested

A fix is available in Nagios Log Server version 2024R1.3.2. Users should upgrade to this version or later to remediate the vulnerability. No other mitigation or workaround information is provided.

Description

Nagios Log Server versions prior to 2024R1.3.2 have a privilege escalation vulnerability in the account email-change workflow. This flaw allows a user to set their email to an invalid value, causing inconsistent account state that can grant elevated privileges or bypass access controls.

References

Community reviews

Loading reviews…