Nats server: Prior to 2.12.8 and 2.11.17, an unauthenticated peer with network access to a leafnode listener with
Affects nats-serverSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 2.12.8 : patch nats-server soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 26.04 LTSnats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10nats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSnats-serverpkg:deb/ubuntu/nats-server?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade NATS Server to version 2.11.17 or 2.12.8 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.
Description
NATS Server versions prior to 2.12.8 and 2.11.17 have a vulnerability that allows an unauthenticated network peer to crash the server by sending repeated leafnode INFO protocol messages during the pre-authentication handshake when compression is enabled. This results in a denial of service by crashing the server before authentication and account setup complete. The issue is fixed in versions 2.12.8 and 2.11.17.
References
- ubuntu.com/security/CVE-2026-58250 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-58250 (opens in a new tab)
- github.com/nats-io/nats-server/security/advisories/GHSA-3g5q-cfh2-cq67 (opens in a new tab)
- github.com/nats-io/nats-server/commit/8dcb26eaea78fdcbe96dbee5986d6019fd5cb94a (opens in a new tab)
- github.com/nats-io/nats-server/commit/fc5fe39177533e9dbdd651d2458285bfae1dde27 (opens in a new tab)
- github.com/nats-io/nats-server/releases/tag/v2.11.17 (opens in a new tab)
- github.com/nats-io/nats-server/releases/tag/v2.12.8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-58250 (opens in a new tab)